Demo

討論

保持飢餓,保持愚笨 (Stay hungry, stay foolish)。 史蒂夫·賈伯斯

公告

本網站已取消討論區的討論方式,如果您有問題請至LINE群行動條碼圖片網址,或Facebook社團

Falang多語網站插件啟用時發生錯誤

  • henrychang
  • henrychang 的個人頭像 Topic Author
  • Offline
  • 新手上路
  • 新手上路
More
2013-01-08 14:30 - 2013-01-08 18:15 #24153 來自 henrychang
henrychang created the topic: Falang多語網站插件啟用時發生錯誤
大家好

我最近在製作一個網站時 Joomla! 2.5.7 MYSQL 5.5.24 PHP 5.3.13

當整體大部分都製作完成後我想添加多語功能 就 下載 http://www.faboba.com/en/composants/falang/donwload.html
這個多語外掛來使用

之前製作其他網站時也都還正常也很好用

不過這次當安裝完外掛與
http://www.okjoomla.com/%E8%AF%AD%E8%A8%80/falang-%E7%BD%91%E7%AB%99%E5%A4%9A%E8%AF%AD%E8%A8%80-1.1.6-joomla-2.5-%E7%AE%80%E4%BD%93%E7%B9%81%E4%BD%93%E4%B8%AD%E6%96%87%E6%B1%89%E5%8C%96-576.shtml
這個繁體中文語系後

當到後台啟用下面的外掛時
外掛名稱 系統 - FaLang Database Driver

進入網站首頁 就出現如下的錯誤訊息
Notice: Undefined index: zh-TW in C:\wamp\www\transbond\components\com_falang\helpers\falang.class.php on line 227

是因為外掛的繁體語系與外掛版本不一樣嗎
可是安裝過程都沒出現錯誤
可以幫我看一下嗎 謝謝


This attachment is hidden for guests.
Please log in or register to see it.









補充一下

各位好 我剛剛又試了一下
發現我後台跟前端預設的語言是 繁體中文
但是只要安裝並啟用了 FaLang Database Driver 後我的首頁 就變成
http://localhost/transbond/index.php/en/
然後就出現 Notice: Undefined index: zh-TW in C:\wamp\www\transbond\plugins\system\languagefilter\languagefilter.php on line 44
不知道該怎麼設定 煩請在幫小弟看看


如果我到後台將預設語言設成 EN (英語)
回到首頁卻又顯是正常(內容都是繁體中文) 但網址依舊是 http://localhost/transbond/index.php/en/
請問該怎麼調整這錯亂的設定呢

This message has an attachment file.
Please log in or register to see it.

最後修改原因: 2013-01-08 18:15 來自 henrychang.

Please 登入 to join the conversation.